Invalid option for langversion hatası ve çözümü

Eğer Invalid option ‘7.2’ for /langversion; must be ISO-1, ISO-2, Default or an integer in range 1 to 6 şeklinde bir hata alıyorsanız muhtemel ki, daha önce projenizi C# 7.2 ile oluşturmuştunuz. Şimdi ise C# 7.2 olmayan bir ortamda çalışıyorsunuzdur. Bu hata benim başıma Visual Studio 2017 ile çalışıp, 2015 ile çalışmaya başladığımda (versiyon düşürdüğümde) aldığım bir hataydı. Hatayı okuduğumuz zaman 7.2 langversion’un olmadığını ISO-1, ISO-2, Default veya 1 ile 6 arasında bir versiyon seçmemizi istemektedir. Tabi burada benim bilgisayarımda bulunan langversion’lardır.

Hata Çözümü

Visual Studio’da projenize sağ tıklayıp Properties >Build menüsüne geliniz. Sağ altta Advanced butonuna tıklayınız. Açılan ekranda Language Version alanında projenizi yazacağınız versiyonu seçiniz. Projeniz sorunsuz çalışacaktır.

Kolay gelsin.

 

Bir cevap yazın

E-posta hesabınız yayımlanmayacak. Gerekli alanlar * ile işaretlenmişlerdir